BLOG - Nachrichten

Die angezeigten Artikel wurden sorgfältig recherchiert. Die Benutzung der Anleitungen geschieht auf eigenes Risiko! Wir übernehmen keinerlei Haftung für materielle oder immaterielle Schäden, die sich aus der Benutzung entstehen oder für Korrektheit des Inhalts.
zur Startseite              Volltextsuche Eingabe leeren
Blog     Kategorien
      Lesezeit: 01:46 Min     135|1   0


Nr. 1176 aus  10 | Internet  160 Blog-Artikel | 4 FAQ
Erstellt So 14.10.2018 20:00  (6 Monate)

Java wird kostenpflichtig

Oracle ändert Lizenzbedingungen von Java für Firmen: Ab Januar 2019 werden alle Java-Versionen größer als Version 8 Update 192 kostenpflichtig für gewerbliche oder produktive Nutzung. Updates der neueren Versionen werden dann auch nicht mehr öffentlich zum Download angeboten, sondern nur mit Oracle-Konto.

:N Nein Das bedeutet für alle Firmen: Das unter Angreifern und Hackern wegen seiner Sicherheitslücken sehr beliebte #Java darf nicht mehr aktualisiert werden, weil man ansonsten gegen die Lizenzvereinbarungen verstößt. Die Lizenz kann man auch nicht kaufen, sondern muss sie pro Named User, der eine Java Runtime (JRE) produktiv nutzen könnte, monatlich mieten.

Da Lizenzbestimmungen nicht rückwirkend für die vorhandenen 8er- bzw. ältere Versionen geändert werden können, bleibt nur der Ausweg, die Java Update-Dienste zu stoppen und nachhaltig und konsequent zu verhindern, dass Java Updates installiert werden. Auch bei Neu-Installationen von Rechnern, Servern und Software muss darauf geachtet werden, dass keine neuere Version als 8 Update 192 installiert und betrieben wird.

:J Ja Werden Java Programme lokal auf dem Rechner betrieben, die keinen Web-Browser benötigen (hierzu zählt das Werkzeug "Secsigner" von Seccommerce zum Überprüfen von signierten Rechnungen durch den Rechnungsempfänger), so kann man die GPLv2 lizensierte OpenJDK Umgebung installieren, Registrierungseinträge machen und nutzen.

:J Ja Die bessere Alternative - vor allem aus Sicherheitsaspekten wird natürlich sein, Java komplett von allen Systemen zu entfernen. Konsequenz ist, dass einige System-Software-Werkzeuge der Hersteller (z.B. FTS RAID Manager) dann nicht mehr genutzt werden können. Schon heute lassen sich alte HP-Jetdirect Boxen nicht mehr administrieren, weil sie Java 6 in 32-Bit erfordern.
Bei Nutzung von aktueller Vmware Vsphere bleibt nur der Ausweg, die Vcenter HTML5 Oberfläche zu benutzen und nicht die Java-basierte Oberfläche.
Wer eine Lizenz für die Konsolen-Weiterleitung beim IRMC erworben hat, findet in den Einstellungen der meisten neueren Weboberflächen die Möglichkeit, dort auf HTML5 umzustellen. Schon kann vom PC mit Webbrowser ohne Java die Serverkonsole/das BIOS erreicht werden.

Anbieter von in Java programmierter Software, die nicht auf #OpenJDK basiert, sondern auf Oracles Java SE basiert, können das nur tun, wenn der Anbieter selbst und seine Kunden monatlich Lizenzgebühren an Oracle dafür zahlen.

Fazit: Kostenlos sind nur - Java Runtimes deinstallieren, OpenJDK für lokale Java Anwendungen einsetzen oder (für Java Webanwendungen) Sicherheitslücken und hohe Risiken dulden. Alle anderen Varianten erfordern auch für die Clients monatliche Lizenzgebühren an Oracle.

Hinweis: Dies ist keine Rechtsberatung, sondern nur eine Faktensammlung auf Basis der Lizenzvereinbarung von Java 8 Update 192.

Stichtag:   Java Version 8 und neuer - weitere Sicherheits-Updates sind …02.02.2019

Wie hat Ihnen der Artikel gefallen?

 10  9  8  7  6  5  4  3  2  1  
Patrick Bärenfänger ist seit über 28 Jahren in der IT-Branche tätig und beschäftigt sich speziell mit Web-Design, Web-Anwendungen, Mobilität, neuer Software und Hardware im PC und Mobilfunkbereich, Kommunikation und IT-Sicherheit.
Windows NewsJava-Alternativen

Das könnte Sie auch interessieren:
  • Adobe-Reader X (Version 10) verfügbar
  • Auch als Lite-Version von sereby.org erhältlich. Wer gänzlich auf den
  • Sicherheitsaktualisierungen ohne Ende
  • Wieder einmal ist eine Menge Arbeit notwendig, um auf Ihren Systemen m
  • Wichtige Software-Aktualisierungen wegen Sicherheitslücken
  • Adobe Shockwave Player Adobe Reader 9.3.2 Adobe Flashplayer Activ
  • Suns Java 6 muss auf Patchlevel 15 gebracht werden
  • denn auch hier wurden wieder Sicherheitslücken festgestellt. (JRE 6.0
  • Adobe-Reader wurde auf Version 9.1.3 aktualisiert
  • und damit kritische Sicherheitslücken geschlossen. Unbedingt aktualisi

    Java   OpenJDK